LG G3s stuck on boot screen

LG G3

Hello everyone

To get straight to the point, I have a ( kinda old ) LG G3s D722 if I’m saying the correct version.
The problem is that it stucks on the LG logo screen when it boots up even
a) after every factory reset ( I press power button and volume down button, then press them again to get on factory reset options to click yes etc. the typical proccedure ) it doesn’t fix the issue.
b) after firmware update which seems to fix the issue in most cases in the past but now it doesn’t ( once the download finishes the phone boots normally like a format has performed and you setup everything from the begining etc. so it’s working )
This morning I got into download mode, performed with the software “flash tool” a normal flash and it worked. Got the phone working normally however ( unfortunately ) I made a software OS update ( LG or android not sure which one exactly ) and after it installed it and performed the usual reboot, it stucked again on LG logo screen. Then I tried the same firmware update method again 2 times and after the download finishes, the phone reboots ( as always ) in order to get in the setup menu to configure the basic starting settings etc. BUT it still stucks on LG logo screen now again.
Moreover, on drfone app I cannot try anything because I get the USB debugging thing which I can’t have access to change since I can’t open the phone.
What do you think I could try?

Any advice or help is greatly appreciated

Thank you very much in advance

Bill

Source

Sharing is caring!

Leave a Reply